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WindSim 4.7.0, demo version 

Introduction 

WindSim is software dedicated to design of wind parks. It´s possible to perform numerical 

simulations of the wind field (speed, direction, turbulence) over a given digital terrain. The 

best location for the wind turbines is therefore found by coupling the wind field results with 

long term wind measurements, by usage of statistical means. It´s also possible to estimate 

the loads on the wind turbines once the wind turbulence has known. Different layouts of wind 

parks provide therefore different energy production but also different loads on the turbines. 

The described process typical of a micrositing project can be carried out with the software 

WindSim, which is subdivided in six modules covering the steps to be taken in a wind park 

drawing: 

�  Import digital terrain map. Terrain module; 

�  Calculate flow field over the given terrain. Wind Fields module; 

�  Place wind turbines and measurements stations. Objects module; 

�  Analyse the flow field. Results module; 

�  Combine wind field data with anemometers data by statistical means to provide: 

o Mean wind maps. Wind Resources module; 

o Annual Energy Production (AEP) for the chosen layout. Energy module. 

 

A typical screen shot of WindSim is shown in Figure 1, the Result module is enabled and a x 

component of wind speed contour map is visualised. 

About the technology 

WindSim 4.7.0 is software for wind energy assessment, based on Computational Fluid 

Dynamics (CFD) simulations of the wind flow over given terrains. The CFD simulations are 

based on the integration of Reynolds Averaged Navier-Stokes (RANS) equations over a 

portion of the lower atmosphere, the computational domain. The RANS equations are 

discretised on a computational grid and integrated with a finite-volume procedure, two 

solvers are available, a segregated and a coupled one. Turbulence is taken into account 

using the standard k-epsilon turbulence model which allows closing the set of equations. 

WindSim is therefore able to assess wind resources with a higher degree of accuracy than 

other tools with simpler computational models. Even terrain with fairly complex features can 

be processed with WindSim. 

The demo version of WindSim contains all the features of the commercial version. The only 

restriction that has been put to the demo version is the maximum number of cells used to 

discretise the computational domain, with 5000 cells in total, and with 10 layers of cells 
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vertically. The limit on the number of cells, as will be shown in the following paragraphs, has 

two effects: it smooths all the features of the given topography and it introduces significant 

discretization errors. The results obtained with the demo version of WindSim are therefore 

not trustable for a wind park project but you will be able to explore all the components of the 

software with this tutorial and also appreciate the power of the commercial version. 

 

Figure 1. Screen shot of WindSim, Results module active. 

Installation 

Download the demo version of WindSim 4.7.0 from the website www.windsim.com or from 

the demo CD and run the installation file. 

 

WindSim is by default installed in C:\Program Files\WindSim,  while the working folder 

where WindSim projects get stored is located in the My Documents\WindSim projects  

folder. You may of course change this default folder setting during the installation. 

 

Once WindSim is installed it can be run from the link added on the desktop or from the list of 

programs in the Start Menu of Windows. 
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Explanation of controls, some nomenclature 

The program consists of the following components: 

�  Title bar  

�  Menu bar  

�  Module selector  

�  Information pages  

o Description  

o Report  

�  Task list 

�  Properties  

�  Property information  

�  Processing output  

Title bar 

The title bar consists of the following items:  

 

�  The WindSim logo  

�  Name of the program: WindSim  

�  Name of the current project  

�  Name of the current layout  

 

 

Menu bar 

The menu bar consists of the following items:  

 

�  File 

�  Layouts 

�  Modules 

�  3D Visualisation  

�  Tools 

�  Help  
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File 

Under the File drop-down menu, you will find all the controls needed for File management:  

�  New 

o Project    Create a new project  

o Project copy   Create a new copy of the current project  

o Layout copy   Create a new copy of the layout(1) for the current 

    project  

�  Open 

o Project    Open a project  

o Layout    Open a layout(1)  belonging to the current project  

�  Recent Projects    List of the recently used projects  

�  Remove 

o Project    Remove the current project  

o Layout    Remove the current layout belonging to the  

    current project  

�  Print      Print the currently displayed page  

�  Print Preview   Preview the currently displayed page before 

 printing  

�  Save      Save the current project 

�  Revert to saved   Come back to the saved situation 

�  Properties    Open a window with summarized main  

      information on the current project 

�  Exit      Exit WindSim 

 
(1) Layout: when a project has more than one layout, the Terrain and Wind Fields will remain 

the same. Layout copy enables you to test different wind farm configurations using the same 

Terrain and Wind Fields data. 

Layouts 

Under the Layouts drop-down menu, the following commands are available: 

�  Create copy    create a new layout as a copy of the current one 

�  Rename layout “Layout 1”  rename the current layout 

�  List of loaded layouts    tick off the layout you want to activate 

�  Texture 

o Open    Load a .bmp or .rgb texture to paste over         

    the terrain 

o List of loaded textures  tick off the texture you want to activate 
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Modules 

Here you can select which module you want to run. The functionality of each module is 

described in more depth later in this document. The present drop-down menu is equivalent to 

use the Module Selector: 

�  Terrain  

�  Wind Fields  

�  Objects  

�  Results  

�  Wind Resources  

�  Energy  

3D Visualisation 

You can choose several 3D Visualisation items:  

�  Generate 3D wind visualisation file (*.vtf) Generate a wind visualisation file  

�  Open 3D wind visualisation file (*.vtf)  Open a wind visualisation file 

�  Download 3D samples   Download .vtf files from the WindSim 

       website. 

The 3D samples in .vtf format can be opened with the application for post-processing GLview 

Pro (provided with the full installation of WindSim) or with GLview express (freely available). 

Tools 

There are several options:  

�  View terrain model (*.gws)    View the terrain model in a text editor  

�  Import terrain model (*.gws)    Import a terrain model to WindSim  

�  Convert terrain model    Convert terrain data from other formats 

       to the WindSim terrain format, *.gws  

�  View climatology data (*.wws)   View the climatology file in a text editor  

�  Import climatology file (*.wws)   Import a climatology file to WindSim  

�  Convert climatology data    Convert climatology data from other  

       formats into the WindSim format; *.wws  

�  Import objects (*.ows)    Import objects into WindSim from a *.ows 

       file 

�  Export object (*.ows)    Export objects in the current layout to a 

       *.ows file 

�  Export HTML report    Generate a complete report for your  

       project in HTML format 

�  Change language    Change the current language 
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�  Limits      Click to see the limits in modeling of  

       WindSim 

Help 

Here you can find:  

�  About WindSim     Contains information about the program, 

       and an application for renewing the  

       hardware key(2); 

�  Tutorial      Open the present document in *.pdf  

       format. 
(2) Hardware key is only needed for the commercial version, not for the demo version. 

Module selector 

The Module Selector, Figure 2, consists of the following headings: 

�  Terrain  

�  Wind Fields  

�  Objects  

�  Results  

�  Wind Resources  

�  Energy  

 

 

Figure 2. Module selector. 

By clicking on one of the buttons the corresponding module will be activated. 

When a module is colored in red, it has not yet been run. When it is orange, it is currently 

running and when a module is green, it has been correctly run. Please note that there are 

important dependencies between modules. You must first run the Terrain module in order to 

establish the computational model to successively generate the wind database. When the 

Terrain module is green, you may run the Wind Fields module. 

In the Wind Fields module you generate the wind database, which contains detailed 

information about the wind field through-out the computational model that you established in 

the Terrain module. If you now go back to the Terrain module and change any of the 

parameters, then the Terrain module will become red (it needs to be rerun), and so will do 

the Wind Field module (it does no longer contain a wind database that is compatible with the 

terrain model you have defined in Terrain). 
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Once you have calculated the terrain model and the wind database (Terrain and Wind Fields 

modules are green), then you may start working with the other modules. In order to get any 

useful results, you must run the Objects module in order to establish where the climatology 

data has been collected and to design the layout of the wind park. The wind data are 

visualized in the Results model which needs therefore the Terrain and Wind Field correctly 

run (green) to be launched. The wind measurements contained in the climatology files are 

then used to weight the wind database in order to get realistic data about how the wind is 

influenced by the terrain in the Wind Resources module. The wind turbines locations and 

power curves loaded in the Objects module are instead needed together with wind 

measurements by the Energy module to compute an estimation of energy production. 

The best way to get a good feel for these dependencies is to get started working with 

WindSim. Please refer to the example project we describe later in this document for further 

guidance. 

Information pages 

 

By clicking on one of the two links you are able to toggle between the corresponding pages.  

 

You can use the back and forward buttons to browse the information pages. 

Description pages 

The description pages describe the active module and which properties you can use for your 

project. 

 

The Description page header displays information about which module the description page 

belongs to. There is also information about the WindSim version and the date it was last 

updated. 

Report pages 

The report pages contain the results from the corresponding module. 

 

The Report pages header contains information about the project. There is information about 

the User, Customer, Project name, Layout, Revision number and also the date and time the 

report has been generated. 
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Task list 

 

The task list gives information about the current module. It tells you what you can do or 

whether it is currently busy. 

When the “Start ” button is red it means it has not been run correctly yet. An orange color 

means that the module is currently running and when it is green is has been run correctly. 

 

Properties 

In the Properties panel located on the top right hand side of the screen you can specify many 

settings. Every module has its own set of properties. Explanations of these properties can be 

found in the Description pages. You can click on the property you want to insert, type the 

values desired or use the arrow keys to move up and down through when a list of options is 

provided to make your selection. 

When you need to specify more values for a property semicolons are used to separate them. 

Press the Enter key when you are done entering the new value, or click somewhere outside 

the current input field in order to set the new value. 
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Property information 

This frame, which you find on the right side under the Properties panel, contains information 

about the currently selected property. For example, in the figure below, the user has selected 

the “Height above terrain” property; at the bottom of the figure you see the Property 

information field that describes shortly the significance of this property. Please remember 

that more detailed information about the property is also found in the Description page of the 

current module. 

 

Processing output 

Here you will see the output concerning the module which is currently running (or just 

finished).  

This may contain confirmation that the module has been run correctly, or otherwise it will 

display errors, warnings, or additional information.  
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Demo: Hundhammerfjellet project 

In the present demo we look at the site of Hundhammerfjellet, located on the coast in the mid 

part of Norway. 

 

WindSim contains six modules. A complete project passes through all the modules as you 

are going to do in the present demo. 

 

Open WindSim and start a new project by choosing:  File > New > Project. 

The New Project window is opened, Figure 3; set your project location by browsing your hard 

drive, push the button  or use the default path, (C:\Documents and 

Settings\User_name\My Documents); leave the Layout name as Layout 1, and enter the 

name of you customer in the Customer field. If no GWS file is specified, then the grid.gws 

with the terrain from Hundhammerfjellet will be automatically copied from the WindSim 

installation area. 

 

 

Figure 3. New Project window. 

Elevation and Roughness data are read from the grid.gws file and imported in the new 

WindSim project. Click OK in order to create the project. 
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Terrain 

The first step in the micro-siting of a wind farm is the generation of a 3D model in the Terrain 

module. This involves choosing the horizontal extension of the area to simulate and the 

height above ground that you want to use in your simulations. This volume (computational 

domain) is then discretized into a system of hexahedral cells called grid or mesh. The 

computational domain is therefore built on a digital terrain in *.gws format containing 

information about elevation and roughness. 

 

WindSim can be run by using the default settings in properties, or the user defined settings 

can be specified. Notice that all bold settings in the Properties panel are the ones that have 

been specified by the user. 

 

In the Demo version of WindSim, the maximum number of cells in vertical direction has been 

set to 10 while the total maximum number of cells has been limited to 5000. In the 

commercial version of WindSim the maximum number of cells would typically be limited by 

the available computer resources. Models with several million cells could be simulated on a 

high performance PC. The very restrictive limitation of the size of the computational model 

means that you cannot trust the results of simulations run with the demo version of WindSim. 

 

Run the Terrain module by clicking on the Start button with the default settings (see below). 

 

You should now see the Figure 4 of Hundhammerfjellet in the Report frame (see figure 

below). 
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Figure 4. Report of Terrain module: 2D Field, Elevation. 

Click on the black arrows in the Report menu of commands to visualize 2D Fields: Elevation, 

Roughness height (z0) with both linear and logarithmic scale, inclination angle (deg), second 

order derivative of the elevation and Delta elevation. The former variable, the delta elevation, 

assumes a value different than zero only when the smoothing option is applied to the model. 

Click on 3D Model  and black arrows to visualize Grid (xy), Grid (z) and Open area. Grid (xy) 

and Grid (z) contain information about the grid spacing and number of cells used for the 

discretization in horizontal and vertical directions. The Open area data is a useful tool to 

understand if too much blockage has been introduced in the generation of the 3D model, a 

Wind Field simulation can be viewed as a numerical wind tunnel test, too much blockage 

would produce unacceptable speed-up. The ratio between minimum and maximum open 

area is used in the automatic generation of the proper height of the 3D model. 
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When you click on 3D, you will see a 3D model in the visualisation tool GLview. The 3D 

visualisation option is available for all the sections 2D Fields, 3D Model and Extension. The 

3D visualisation option is also available in the other modules of WindSim. 

Click on Extension  to visualize in the Report panel the horizontal extension of the generated 

3D model which is marked with a grey frame over an elevation contours map, see Figure 5. 

The contours map for the Extension is based on the original gws file, hence on the maximum 

resolution and not on the 3D model which is coarser than the original digital terrain data. The 

difference in resolution is particularly clear when comparing the two plots of Figure 4 and 

Figure 5. 

 

Figure 5. Horizontal extension of the 3D model. 

If you desire to reduce the extension of the model, it is possible to explore the terrain 

extension in the 3D model, where you can find the needed coordinates. 
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In order to produce a finer mesh, which means smaller discretization errors, in the area of 

interest, where the wind park has to be constructed, a new terrain model is therefore desired 

with user specified properties. Assign a new extension to the terrain model in the Properties 

panel by new X-range and Y-range. Define a refinement area to design an even denser grid 

in the area of interest, where the wind park has to be located, as in the Properties panel in 

Figure 6. 

 

Figure 6. Properties panel, new extension and refined area. 

In this way you have now cropped from the original gws file only an area covering the ridge 

of Hundhammerfjellet, where the wind park will be located. The borders of the computational 

domain are still quite far from the area of interest in order to avoid boundary effects. 

 

Click on Terrain > Report > Extension  to get the Figure 7 in the Report frame, which shows 

the extension of the new 3D model compared to the original gws terrain data. Note that when 

refinement is applied, the horizontal resolution varies; its minimum and maximum values are 

available in the Report > 3D Model and Grid (xy) . 

 

Click on Terrain > Report > 3D Model,  and then select Grid (xy)  using the black arrows to 

obtain the report on the horizontal discretization of the generated 3D Model, Figure 8. 

 

Click on Terrain > Report > 3D Model  and then select Grid (z)  using the black arrows to obtain 

the report on the vertical discretization of the generated 3D Model, Figure 9. 

 

Click on Terrain > Report > 3D Model  and then select Open area  by using the black arrows to 

obtain the Figure 10. The criteria named Open area which account for the ratio of minimum 
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and maximum area of the intersections of the computational domain with vertical planes 

south-north and west-east directed. The wind field simulations can be seen as numerical 

wind tunnel runs, hence it is important to reduce the blockage effect which produces 

unphysical speed-up. The ideal height of the 3D model is computed automatically in order to 

keep this ratio to an acceptable value close to one.  

 
The digital terrain model, marked as a box, is extracted from grid.gws.  

 

Figure 7. Terrain > Report > Extension. 
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Figure 8. Terrain > Report > 3D Model: Grid (xy). 
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Figure 9. Terrain > Report > 3D Model: Grid (z). 
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Figure 10. Terrain > Report > 3D Model: Open area. 

Wind Fields 

Once the generation of the 3D model has been completed in the Terrain module, the CFD 

simulations of the wind fields can start. The wind fields are determined by solving the 

Reynolds Averaged Navier-Stokes equations (RANS), accounting for the continuity and 

momentum equations time or Reynolds averaged. The standard k-epsilon model is applied 

as turbulence closure. Since the equations are non-linear, the solution procedure is iterative. 

The RANS equations are discretized and integrated with a finite-volume methodology. 

Starting with the initial conditions, which are guessed estimations, the solution is 

progressively resolved by iteration until a converged solution is achieved. Two possible ways 

to solve the RANS equations are available in WindSim: 

 

�  A segregated solver (SIMPLEST) 

�  An algebraic coupled multi-grid solver (MIGAL) 
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Select the Wind Fields module and run the module with default settings. A window pops up 

to let the user follow the development of the flow field during the iterative computation. By 

default the software monitors the 3D magnitude of the velocity vector at the ground level 

(ground adjacent cells). If the simulations have reached a converged solution, you should not 

be able to see any further change in the contours plots monitoring the computational history. 

In the Report you can check whether the modelling has been carried out correctly by 

inspecting the graphs of the Spot and Residual values for all the solved variables, Figure 11 

and Figure 12. 

 

Figure 11. Wind Fields > Report > Spot Values. 
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Figure 12. Wind Fields > Report > Residual Values. 

In the Wind Fields > Report > Field Value menu, it is also possible to see an animation of the 

development of the chosen variable during the iterative process. In well converged 

simulations, the calculated variables should not change any further with iterations. A 

screenshot of the monitored variable is shown in Figure 13. 
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Figure 13. Wind Fields > Report > Field Value. 

Objects 

The Objects module is used to place turbines, climatologies, transferred climatologies and 

geometrical points in the 3D model. Geometrical objects can also be placed within the 3D 

terrain model for visualisation purpose. For Hundhammerfjellet, we have one climatology to 

specify. Click the button in the Properties panel, select Climatology as Object 

type, give a new name to the object, e.g. clima_1, select the visualisation file 

climatology_50.in  and the climatology file 0801-Hundhammer-50m.wws . The Properties panel 

now looks like in Figure 14. Run the module and the climatology object will appear in the 

report section at the centre of the 3D model. The same procedure has to be followed to add 

turbines, transferred climatologies and geometrical points. 
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Figure 14. Properties panel in the Object module. 

Alternatively objects can be read from a .ows files using the Tools > Import objects menu 

item. For Hundhammerfjellet we have an existing layout (a .ows file) with seventeen turbines 

already placed on the ridge. This layout can be read directly by using the Tools > Import 

objects menu item. 

Delete the previously created climatology by clicking on the or 

button. Load the file Hundhammer.ows , 17 wind turbines will be added to the park layout. You 

still need to load the climatology files (.wws) before running the module. Load the Tommerhol 

of wind data using the Tools > Import climatology file (.wws) in the file named 0150-

Tommerhol-30m_1year.wws  which is located in the path:  

 

C:\Program Files\WindSim\WindSim4.7.0\Data\Objects\ Climatology 

 

Repeat the procedure for the climatology station Hundhammer, the climatology file is the 

0801-Hundhammer-30m_1year.wws , both the sets of data are for anemometers 30 m high and 

referred to the same measuring period of 1 year. The object module is now ready to run, click 

on the Start  button. 

All objects are now included in the Hundhammerfjellet project, the layout of the wind park can 

be visualised by selecting the Report > Object representation  menu. The report for the 

Objects module will appear as in Figure 15. The main features of the climatologies and 

turbines within the wind park are listed in the tables 1 and 2 of the report. Further information 

on climatologies and turbines are given if you click on the black triangles in the tables. An 

animation is also available which is activated by Report > Animation  and 3D to open GLview 

Pro . 
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Figure 15. Objects > Report > Object representation. 
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A photo can be pasted on the terrain to provide a more realistic view of the wind park area. 

Load the photo of Hundhammerfjellet Layouts > Texture file > Open … and load the picture 

named hundhammerfjellet.bmp  from the path: 

 

C:\Program Files\WindSim\WindSim4.7.0\Data\Texture 

 

Now tick off the just loaded file from the list of textures in Layouts > Texture file > 

hundhammerfjiellet.bmp. Run the object module again in order to apply the texture. 

If you select texture  in the report page you can get a very realistic view of the wind park 

location. In the report page you can now see the layout of the wind park over the added 

satellite photograph, Figure 16. Click on 3D objects  and the 3D button to get a perspective 

view of the wind park, like shown in Figure 17. 

 

 

Figure 16. Objects > Report > Object representation with Texture. 
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Figure 17. Perspective view of the Hundhammwrfjellet wind park. 

The satellite image has been captured by using the software Google Earth which is freely 

available at http://earth.google.com/ website. A useful tool for the conversion from UTM to 

geographical coordinates and vice versa is given in http://www.gazza.co.nz/geodetics.html. 

Results 

In the Results module you can extract 2D horizontal plane representations from the wind field 

database, covering the vertical extension from ground up to the "Height of reduced wind 

database" as specified in the Wind Field module. 

You can specify different normalization variables: 

 

SpeedScalarX   wind speed scalar in East-West direction, UCRT; 

SpeedScalarY   wind speed scalar in North-South direction, VCRT;  

SpeedScalarZ   wind speed scalar in vertical direction, WCRT; 

SpeedScalarXY  wind speed scalar in horizontal plane,    

    SQRT(UCRT2+VCRT2); 

SpeedScalarXYZ  wind speed scalar in 3D space,     

    SQRT(UCRT2+VCRT2+WCRT2);  

VelocityVectorXY  wind speed vector in horizontal plane, (UCRT,VCRT,0);  



 

 

27 Results 

VelocityVectorXYZ  wind speed vector in 3D space, (UCRT,VCRT,WCRT); 

DirectionScalar  wind direction in horizontal plane in degrees; 

Direction scalar relative wind direction in horizontal plane relative to incoming wind 

direction (degrees) 

Turbulent kinetic energy turbulent kinetic energy, KE (m2/s2) 

Turbulent intensity  turbulent intensity assuming isotropic turbulence,   

    100*SQRT((4/3)*KE)/SQRT(UCRT2+VCRT2) (%) 

Turbulent dissipation rate turbulent dissipation rate, EP (m2/s3) 

Pressure   relative pressure minus hydrostatic term (Pa), the relative  

    pressure has a value equals to zero at the outlet of the domain 

 

In this tutorial we will extract a scalar and a vector variable. Specify for example Wind 

velocity 3D (u,v,w), at 50 m height and Turbulent Kinetic energy at 50 m height. Run the 

module and have a look at the report. The Properties panel looks now like in Figure 18 while 

in Figure 19 and 20 are respectively reported the speed 3D vector and the turbulent kinetic 

energy. 

Note that the height for the extraction of results has been left to the default value which is 50 

m above ground level; several heights can be defined separated by semicolons. Typical 

heights of interest are the hub height of the displaced turbines and the height of wind 

measurements. 

It is important to stress that the results module is a tool for visualisation of the wind field 

simulations, to see how the flow fields are affected by the terrain. The wind speeds are not 

by default calibrated with wind measurements. Non dimensional, normalised, plots are also 

available, you need to choose the desired normalization type in the property grid (see Figure 

18). The Wind Resources and Energy modules are used to weight the CFD with the 

climatology data. 
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Figure 18. Properties panel, Results module. 
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Figure 19. Results > Report.  Wind velocity 3D (m/s) for sector 300° at 50 m a.g.l. 
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Figure 20. Results > Report. Turbulent Kinetic energy (m2/s2) for sector 0° at 50 m a.g.l. 

Wind Resources 

The Wind Resources module is used to create a mean-wind map at chosen heights. 

 

Before running the Wind Resource module, at least one climatology file must exist within the 

model, and all sectors defined in that climatology must exist in the wind database. The wind 

resource map is established by weighting the wind database against the climatology. If 

several climatology objects are available, the wind resource map will be based on them all, 

by interpolation of the inverse distance to the climatology objects. 

 

Run the module with default settings to create a wind resource map (mean wind speed) for 

the Hundhammerfjellet project. But remember, the results are not realistic because of the 

limited size of the computational model of the demo version you are currently running. 
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Figure 21. Properties panel of the Wind Resources module. 
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Figure 22. Wind Resources > Report. 2D mean wind speed at 50 m a.g.l. weighted with all 

climatologies. 



 

 

33 Wind Resources 

 

Figure 23. Wind Resources > Report. 2D mean wind speed at 80 m a.g.l. (hub heigth) weighted with 

all climatologies. 

Wind Resources: wake modelling 

If you are concerned about wake losses in the wind park, also known as wind park effect, 

you can use one of the 3 wake models that are available in WindSim for the treatment of the 

wind field data. Wake models can be used both in the Wind Resources and in the Energy 

modules. 

A complete description of the three models is provided in the description page of the Wind 

Resources module. 

If you now run the Wind Resources module with the three wake modules, the mean wind 

speed is calculated with and without wake model. If more than one climatology is provided 

the mean speed and wake models are calculated in accordance to each climatology or 

weighting all climatologies by inverse distance. 

In Figure 24, Figure 25 and Figure 26 the wake deficits obtained with the three models at hub 

height are plotted. 
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Figure 24. Wake deficit at hub height, wake model 1. 
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Figure 25. Wake deficit at hub height, wake model 2. 
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Figure 26. Wake deficit at hub height, wake model 3. 

Energy 

The annual energy production, AEP, is the most important feature we want to estimate in a 

wind park micrositing project. In a given wind condition, the available power is proportional to 

the cube of the wind speed, which means that uncertainty in wind prediction is tripled when 

computing the available power; hence accuracy is particularly appreciated in wind energy 

assessment. 

 

Run the module by default setting, as shown in Figure 27, and get the annual energy 

production for each turbine hence for the whole wind park. 
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Figure 27. Properties panel for the Energy module, default settings. 

 

The report frame now looks like in Figure 28. For each climatology, two AEP are given in the 

Energy report: the first one is obtained from the frequency table of the climatology files and 

the second is obtained by interpolating the same frequencies with Weibull frequency 

distributions. A quite large difference can be noted in the AEP predicted with the two 

climatologies, about 15 GWh/y. Large part of the discrepancy observed in the two predictions 

comes from the fact we run the demo version of WindSim, where there is a limit of 5000 

cells; discretization errors are therefore considerable. A typical procedure that is followed in 

CFD computations is to pass from coarse grids to finer and finer grids in order to minimize 

the discretization errors, the ideal situation is achieved when the errors are negligible, when 

grid independency has been reached. In the following Figures 29-33 you can see the effects 

of grid sensitivity study on the AEP obtained with further refinements. 

 

 

Figure 28. Report panel for the Energy module, Hundhammerfjellet project (~5000 cells). 
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Figure 29. Report panel for the Energy module, Hundhammerfjellet project (~25000 cells). 

 

 

Figure 30. Report panel for the Energy module, Hundhammerfjellet project (~100000 cells). 

 

 

Figure 31. Report panel for the Energy module, Hundhammerfjellet project (~400000 cells). 

 

 

Figure 32. Report panel for the Energy module, Hundhammerfjellet project (~800000 cells). 
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The AEP calculated with the four different models are summarised in Figure 33. Important 

discretization errors are present when the demo version is run (~5000 cells). Considering a 

grid independency reached with a model of 800 000 cells, a model comprising just 5 000 

cells gave errors of 20 % for one of the climatology data. The model of size 100 000 cells 

provided a good estimation of the AEP, the errors could be considered within 3%; 

considering a grid independency reached with 800 000 cells. 

It´s important to stress out that the characteristic of a grid which is leading to grid 

independency its resolution, hence for wider areas a higher number of cells is required to 

minimise the discretization errors. 

 

Figure 33. AEP for the two climatologies against number of cells used in the 3D models. 

If now you re-run the Energy module with a wake model, for instance the wake model 3, you 

can estimate the AEP corrected with wind park effect. Results are reported in Figure 34 and 

Figure 35 with computation of wake losses respectively with 5 and 20 sub-sectors. 
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Figure 34. Energy > Report. Wake losses computed with 5 sub-sectors. 

 

Figure 35. Energy > Report. Wake losses computed with 20 sub-sectors. 

 


